#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((1\d{2}|2[0-4]\d|25[0-5]|[1-9]?\d)(\.(?=\d)|(?!\d))){4}(/([12]?\d|3[0-2]))?$"
Local $sString = "10.238.51.19" & @CRLF & _
                "12.89.119.255/30" & @CRLF & _
                "12.89.119.25" & @CRLF & _
                "1.2.3.4/24" & @CRLF & _
                "0.0.0.0/0" & @CRLF & _
                "" & @CRLF & _
                "00.00.00.00" & @CRLF & _
                "0.0.0.0.0" & @CRLF & _
                "1.1..123" & @CRLF & _
                "1.1.1234.123" & @CRLF & _
                "1.1.1.123/" & @CRLF & _
                "1.1.456.78" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")