const regex = new RegExp('^((1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]?\\d)(\\.(?=\\d)|(?!\\d))){4}(/([12]?\\d|3[0-2]))?$', 'gm')
const str = `10.238.51.19
12.89.119.255/30
12.89.119.25
1.2.3.4/24
0.0.0.0/0
00.00.00.00
0.0.0.0.0
1.1..123
1.1.1234.123
1.1.1.123/
1.1.456.78
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}