import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((1\\d{2}|2[0-4]\\d|25[0-5]|[1-9]?\\d)(\\.(?=\\d)|(?!\\d))){4}(/([12]?\\d|3[0-2]))?$";
final String string = "10.238.51.19\n"
+ "12.89.119.255/30\n"
+ "12.89.119.25\n"
+ "1.2.3.4/24\n"
+ "0.0.0.0/0\n\n"
+ "00.00.00.00\n"
+ "0.0.0.0.0\n"
+ "1.1..123\n"
+ "1.1.1234.123\n"
+ "1.1.1.123/\n"
+ "1.1.456.78\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}