using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^][]*pause=""(?P<type>[^""]+)""";
string input = @"Hi[pause=""x-weak""]Parth[pause=""weak""]How[pause=""medium""]are[pause=""strong""]You[pause=""x-strong""]tell me";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}