re = /\[[^][]*pause="(?P<type>[^"]+)"/m
str = 'Hi[pause="x-weak"]Parth[pause="weak"]How[pause="medium"]are[pause="strong"]You[pause="x-strong"]tell me'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end