package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*pause="(?P<type>[^"]+)"`)
var str = `Hi[pause="x-weak"]Parth[pause="weak"]How[pause="medium"]are[pause="strong"]You[pause="x-strong"]tell me`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}