import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^][]*pause=\"(?P<type>[^\"]+)\"";
final String string = "Hi[pause=\"x-weak\"]Parth[pause=\"weak\"]How[pause=\"medium\"]are[pause=\"strong\"]You[pause=\"x-strong\"]tell me";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}