const regex = new RegExp('(\\d+)A/(\\d+)B', 'gm')
const str = `30A/305B: both 30 and 305 must be returned;
30/305B: neither 30 nor 305 would be returned;
30A/305: neither 30 nor 305 would be returned;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}