import re
regex = re.compile(r"(\d+)A/(\d+)B", flags=re.MULTILINE)
test_str = ("30A/305B: both 30 and 305 must be returned;\n"
"30/305B: neither 30 nor 305 would be returned;\n"
"30A/305: neither 30 nor 305 would be returned;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")