// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)A/(\d+)B").unwrap();
let string = "30A/305B: both 30 and 305 must be returned;
30/305B: neither 30 nor 305 would be returned;
30A/305: neither 30 nor 305 would be returned;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}