$re = '`(\d+)A/(\d+)B`m';
$str = '30A/305B: both 30 and 305 must be returned;
30/305B: neither 30 nor 305 would be returned;
30A/305: neither 30 nor 305 would be returned;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);