import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<)(\\/|)([a-zA-Z-Z0-9]+))";
final String string = "<!-- Comments Testing -->\n"
+ "<div id=\"page\"><div id=\"header\"><h1><a href=\"#\">Burger Pointer</a></h1><ul class=\"left\"><li><a href=\"#\">Menu</a></li><li><a href=\"#\">Location</a></li><li><a href=\"#\">About Us</a></li><li><a href=\"#\">BP Gear</a></li></ul></div></div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}