import Foundation
let pattern = #"((<)(\/|)(?!a|h1)([a-zA-Z0-9]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<!-- Comments Testing -->
<div id="page"><div id="header"><h1><a href="#">Burger Pointer</a></h1><ul class="left"><li><a href="#">Menu</a></li><li><a href="#">Location</a></li><li><a href="#">About Us</a></li><li><a href="#">BP Gear</a></li></ul></div></div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)