import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[A-Za-z0-9])_([A-Za-z0-9])";
final String string = "f_o_o_b_a_r\n"
+ "foo_bar\n"
+ "foo1_bar1\n"
+ "_foo_bar\n"
+ "foo__bar\n"
+ "trailing_\n"
+ "trailing__\n"
+ "trailing___\n"
+ "____pathological____case_____";
final String subst = "\\U$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}