$re = '/(?<=[A-Za-z0-9])_([A-Za-z0-9])/m';
$str = 'f_o_o_b_a_r
foo_bar
foo1_bar1
_foo_bar
foo__bar
trailing_
trailing__
trailing___
____pathological____case_____';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;