const regex = /(?<=[A-Za-z0-9])_([A-Za-z0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Za-z0-9])_([A-Za-z0-9])', 'gm')
const str = `f_o_o_b_a_r
foo_bar
foo1_bar1
_foo_bar
foo__bar
trailing_
trailing__
trailing___
____pathological____case_____`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);