import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\\.com$)";
final String string = "abc\n"
+ "abs@gmail.com sss\n"
+ "abs@gmail.comsss\n"
+ "aaaabs@gmail.com\n"
+ "aaa abs@gmail.com\n"
+ "abc@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}