re = /^(?![a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.com$)/m
str = 'abc
abs@gmail.com sss
abs@gmail.comsss
aaaabs@gmail.com
aaa abs@gmail.com
abc@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end