package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)`)
var str = `0.9
-.4
-0.5
9
-6
-1.0e-1
-10.56e-1
2.93847293841270e+16
-4.65981524854648e+16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}