$re = '/(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)/m';
$str = '0.9
-.4
-0.5
9
-6
-1.0e-1
-10.56e-1
2.93847293841270e+16
-4.65981524854648e+16';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);