import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?\\d*(?:\\.?\\d*)?(?:e[-+]?\\d*)?)";
final String string = "0.9\n"
+ "-.4\n"
+ "-0.5\n"
+ "9\n"
+ "-6\n"
+ "-1.0e-1\n"
+ "-10.56e-1\n"
+ "2.93847293841270e+16\n"
+ "-4.65981524854648e+16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}