#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\.\s.*(?:\n(?!\s*[A-Z]).*)*(?:\n[A-Z]\.\s.*(?:\n(?!\s*(?:\d+|[A-Z])\.\s).*)*)*"
Local $sString = "1. this is a question?" & @CRLF & _
"A. This is an answer" & @CRLF & _
"B. This is an answer" & @CRLF & _
"" & @CRLF & _
"2. this is a question?" & @CRLF & _
"A. This is an answer" & @CRLF & _
"B. This is an answer" & @CRLF & _
"" & @CRLF & _
"3. this is a question" & @CRLF & _
" multiline?" & @CRLF & _
"A. This is an multiline" & @CRLF & _
" answer" & @CRLF & _
"B. This is an answer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")