use strict;
my $str = '1. this is a question?
A. This is an answer
B. This is an answer
2. this is a question?
A. This is an answer
B. This is an answer
3. this is a question
multiline?
A. This is an multiline
answer
B. This is an answer';
my $regex = qr/^\d+\.\s.*(?:\n(?!\s*[A-Z]).*)*(?:\n[A-Z]\.\s.*(?:\n(?!\s*(?:\d+|[A-Z])\.\s).*)*)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}