using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\.\s.*(?:\n(?!\s*[A-Z]).*)*(?:\n[A-Z]\.\s.*(?:\n(?!\s*(?:\d+|[A-Z])\.\s).*)*)*";
string input = @"1. this is a question?
A. This is an answer
B. This is an answer
2. this is a question?
A. This is an answer
B. This is an answer
3. this is a question
multiline?
A. This is an multiline
answer
B. This is an answer";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}