$re = '/^\d+\.\s.*(?:\n(?!\s*[A-Z]).*)*(?:\n[A-Z]\.\s.*(?:\n(?!\s*(?:\d+|[A-Z])\.\s).*)*)*/m';
$str = '1. this is a question?
A. This is an answer
B. This is an answer
2. this is a question?
A. This is an answer
B. This is an answer
3. this is a question
multiline?
A. This is an multiline
answer
B. This is an answer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);