package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?`)
var str = `Em01_Trq = 500 rpm
Em01_Trq=-500rpm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_Trq>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}