use strict;
my $str = 'Em01_Trq = 500 rpm
Em01_Trq=-500rpm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_Trq>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm';
my $regex = qr/([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}