const regex = /(\d+).*?(,(?=.*\d))|\D/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+).*?(,(?=.*\\d))|\\D', 'gm')
const str = `,,,,1,,2dgd,d,`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);