$re = '/(\d+).*?(,(?=.*\d))|\D/m';
$str = ',,,,1,,2dgd,d,';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;