use strict;
my $str = ',,,,1,,2dgd,d,';
my $regex = qr/(\d+).*?(,(?=.*\d))|\D/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";