#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z0-9]+):([a-z0-9]+);([a-z0-9]+):([a-z0-9]+);?"
Local $sString = "k1:v1;k2:v2; => valid format" & @CRLF & _
"k1:v1;k2:v2 => valid format" & @CRLF & _
"somekey:value;k2:v2; => valid format" & @CRLF & _
"k1,v1;k2,v2 => invalid format" & @CRLF & _
"k1 v1; k2 v2; => invalid format"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")