package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z0-9]+):([a-z0-9]+);([a-z0-9]+):([a-z0-9]+);?`)
var str = `k1:v1;k2:v2; => valid format
k1:v1;k2:v2 => valid format
somekey:value;k2:v2; => valid format
k1,v1;k2,v2 => invalid format
k1 v1; k2 v2; => invalid format`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}