re = /([a-z0-9]+):([a-z0-9]+);([a-z0-9]+):([a-z0-9]+);?/m
str = 'k1:v1;k2:v2; => valid format
k1:v1;k2:v2 => valid format
somekey:value;k2:v2; => valid format
k1,v1;k2,v2 => invalid format
k1 v1; k2 v2; => invalid format'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end