using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z0-9]+):([a-z0-9]+);([a-z0-9]+):([a-z0-9]+);?";
string input = @"k1:v1;k2:v2; => valid format
k1:v1;k2:v2 => valid format
somekey:value;k2:v2; => valid format
k1,v1;k2,v2 => invalid format
k1 v1; k2 v2; => invalid format";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}