const regex = /((^|;)Password=)(.*?)(;|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^|;)Password=)(.*?)(;|$)', 'gim')
const str = `Host=SERVERNAME;Port=####;Database=DBNAME;Username=USERID;Password=MyPa\$\$Word;Integrated Security=False
Host=SERVERNAME;Port=9999;Password=MyPa\$\$Word;Database=DBNAME;Username=USERID;Integrated Security=False
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=MyPa\$\$Word
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=Password`;
const subst = `$1PASSWORD_REMOVED$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);