use strict;
my $str = 'Host=SERVERNAME;Port=####;Database=DBNAME;Username=USERID;Password=MyPa$$Word;Integrated Security=False
Host=SERVERNAME;Port=9999;Password=MyPa$$Word;Database=DBNAME;Username=USERID;Integrated Security=False
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=MyPa$$Word
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=Password';
my $regex = qr/((^|;)Password=)(.*?)(;|$)/imp;
my $subst = '$1PASSWORD_REMOVED$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";