#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\S)A[0-9]+(?:[-+%~^*]+A?\d+(?:\.\d+)?)+(?!\S)"
Local $sString = "A1++(10+20) " & @CRLF & _
"A1+500+4 but it is taking input as A1++5%/ c " & @CRLF & _
"A1+100-A5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")