import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)A[0-9]+(?:[-+%~^*]+A?\\d+(?:\\.\\d+)?)+(?!\\S)";
final String string = "A1++(10+20) \n"
+ "A1+500+4 but it is taking input as A1++5%/ c \n"
+ "A1+100-A5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}