const regex = /(?<!\S)A[0-9]+(?:[-+%~^*]+A?\d+(?:\.\d+)?)+(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)A[0-9]+(?:[-+%~^*]+A?\\d+(?:\\.\\d+)?)+(?!\\S)', 'g')
const str = `A1++(10+20)
A1+500+4 but it is taking input as A1++5%/ c
A1+100-A5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}