$re = '/(?<!\S)A[0-9]+(?:[-+%~^*]+A?\d+(?:\.\d+)?)+(?!\S)/';
$str = 'A1++(10+20)
A1+500+4 but it is taking input as A1++5%/ c
A1+100-A5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);