const regex = /^[0-9a-fA-F]{1,2}$|^[0-9a-fA-F]{1,2}\s+([0-9a-fA-F]{1,2}\s)*[0-9a-fA-F]{1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9a-fA-F]{1,2}$|^[0-9a-fA-F]{1,2}\\s+([0-9a-fA-F]{1,2}\\s)*[0-9a-fA-F]{1,2}$', 'gm')
const str = `0
00
000
0000
00000
000000
aa bb cc dd ee ff 00
AA BB CC DD EE FF
00
00
00 0
00 00
00 00
00 00 0
00 00 00 00
00 00 00
00 00 00 00 00 00 00 00 00
aa bb cd ef 11 dd
a bf 11 cd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}