import Foundation
let pattern = #"^[0-9a-fA-F]{1,2}$|^[0-9a-fA-F]{1,2}\s+([0-9a-fA-F]{1,2}\s)*[0-9a-fA-F]{1,2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
00
000
0000
00000
000000
aa bb cc dd ee ff 00
AA BB CC DD EE FF
00
00
00 0
00 00
00 00
00 00 0
00 00 00 00
00 00 00
00 00 00 00 00 00 00 00 00
aa bb cd ef 11 dd
a bf 11 cd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)