// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<p.+id="sinopse2"[^>*]*>(.*)<\/p>"#).unwrap();
let string = "<p id=\"sinopse2\" style=\"display:block !important;\">VALOOR</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}