#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^:]*:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?)\D*?(-?\d+(?:\.\d+)?)"
Local $sString = ""Coordenadas: 0, 63, -5|hhhf♀"" & @CRLF & _
"" & @CRLF & _
""Coordenadas: 0, 63.5, -5.695|hhhf♀"" & @CRLF & _
"" & @CRLF & _
""Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀"" & @CRLF & _
"" & @CRLF & _
""Coordenadas: -8, 63, -5 \n♀"" & @CRLF & _
"" & @CRLF & _
""Coordenadas: 0, 63, -5""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")