import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^:]*:\\s*(-?\\d+(?:\\.\\d+)?),\\D*?(-?\\d+(?:\\.\\d+)?)\\D*?(-?\\d+(?:\\.\\d+)?)";
final String string = "\"Coordenadas: 0, 63, -5|hhhf♀\"\n\n"
+ "\"Coordenadas: 0, 63.5, -5.695|hhhf♀\"\n\n"
+ "\"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀\"\n\n"
+ "\"Coordenadas: -8, 63, -5 \\n♀\"\n\n"
+ "\"Coordenadas: 0, 63, -5\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}