import re
regex = re.compile(r"^[^:]*:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?)\D*?(-?\d+(?:\.\d+)?)", flags=re.MULTILINE)
test_str = ("\"Coordenadas: 0, 63, -5|hhhf♀\"\n\n"
"\"Coordenadas: 0, 63.5, -5.695|hhhf♀\"\n\n"
"\"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀\"\n\n"
"\"Coordenadas: -8, 63, -5 \\n♀\"\n\n"
"\"Coordenadas: 0, 63, -5\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")