// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^:]*:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?)\D*?(-?\d+(?:\.\d+)?)").unwrap();
let string = "\"Coordenadas: 0, 63, -5|hhhf♀\"
\"Coordenadas: 0, 63.5, -5.695|hhhf♀\"
\"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀\"
\"Coordenadas: -8, 63, -5 \\n♀\"
\"Coordenadas: 0, 63, -5\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}