import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":61:(\\d+)(\\D{1,2})(\\d+|\\d+,\\d{1,2})([A-Z]{4})(?=//)//(.{0,})";
final String string = ":61:240826DR176120660NTRF//0207150143062089\n"
+ ":61:240826DR176120660,0NTRF//0207150143062089\n"
+ ":61:240826CR176120660,0NTRF//0207150143062089\n"
+ ":61:1507020702D115945,00F014NARRATIVE//0207150143062089\n\n"
+ ":61:170929D546232,05S101PLTOL101-56//C11126A1378\n\n"
+ ":61:170929D100000,NFEXAAAAUS0369PLATUS//8954321\n\n"
+ ":61:090124D10000000,S202DRS/06553";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}