import re
regex = re.compile(r":61:(\d+)(\D{1,2})(\d+|\d+,\d{1,2})([A-Z]{4})(?=//)//(.{0,})", flags=re.MULTILINE)
test_str = (":61:240826DR176120660NTRF//0207150143062089\n"
":61:240826DR176120660,0NTRF//0207150143062089\n"
":61:240826CR176120660,0NTRF//0207150143062089\n"
":61:1507020702D115945,00F014NARRATIVE//0207150143062089\n\n"
":61:170929D546232,05S101PLTOL101-56//C11126A1378\n\n"
":61:170929D100000,NFEXAAAAUS0369PLATUS//8954321\n\n"
":61:090124D10000000,S202DRS/06553")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")