const regex = new RegExp(':61:(\\d+)(\\D{1,2})(\\d+|\\d+,\\d{1,2})([A-Z]{4})(?=//)//(.{0,})', 'gm')
const str = `:61:240826DR176120660NTRF//0207150143062089
:61:240826DR176120660,0NTRF//0207150143062089
:61:240826CR176120660,0NTRF//0207150143062089
:61:1507020702D115945,00F014NARRATIVE//0207150143062089
:61:170929D546232,05S101PLTOL101-56//C11126A1378
:61:170929D100000,NFEXAAAAUS0369PLATUS//8954321
:61:090124D10000000,S202DRS/06553`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}